Jump to content


News & Updates

Notice [5/01/2014]: Video Game Paradise will probably be shutting down at the end of this year however it may remain open if we can get the activity up.


Photo

Separate Installs for PlugY in 1.12 and 1.13


  • Please log in to reply
5 replies to this topic

#1 Explopyro

Explopyro

    Moderator

  • Moderators
  • 1,626 posts
  • Location: Pittsburgh, PA

Posted 23 March 2010 - 06:24 PM

Now that 1.13 has been released, the most recent version of PlugY (v9.00) is no longer compatible with the current patch of the game. As such, until such time as a new version is released, if we want to use it to enable content (the Uber Quest and/or Diablo Clone), it will be necessary to use multiple installations of the game in order to be able to use it. I just thought I'd make a topic explaining a method for doing so, in order to facilitate the process.

Two methods will work:

(1) If you haven't updated to 1.13 yet, simply copy the Diablo II folder in your Program Files (or comparable) directory, then name the second one something convenient. You can then install 1.13 in one directory, rename it, rename the other directory to Diablo II and install PlugY. Whenever you want to switch versions, just change the name of the folder for the install you want to run from to Diablo II and move your save folder to that directory.

(2) If you've already installed 1.13, rename your Diablo II folder in Program Files (or wherever it is), then reinstall the game from scratch (either from the discs or from Blizzard's digital download) and update to 1.12, then install PlugY. You can then change versions by renaming whichever install you wish to use to Diablo II and moving your save folder.

There are of course other ways to do this, but those methods will both work (although I will admit that they require a bit of disk space, D2X takes up a little under 2 GB and so will the second install).

The reason you need to rename the folders is because PlugY doesn't know where to look for the rest of the game files unless it's in the Diablo II folder. If you want to avoid having to rename the files in order to change versions, you can follow this process:

(1) Install 1.13
(2) Rename the Diablo II folder to something else, say "Diablo II - v1_13"
(3) From the new location, create a shortcut to the Diablo II executable and put it someplace convenient; name the shortcut such that you'll remember it's for 1.13
(4) Install Diablo II again and update to 1.12 (NOT 1.13)
(5) Install PlugY
(6) Create a shortcut to PlugY.exe in a convenient place
(7) Move your save folder to the Diablo II folder (the 1.12 one, the folder named Diablo II)
(8) ...
(9) Profit!

The reason you do that is because both versions of Diablo II will look for the save folder in the Diablo II directory (although you can probably change that if you want to, I think it might involve editing registry files and I don't want to get into that), but you can run 1.13 just fine from the renamed folder (PlugY can't, it will look for the game in Diablo II).

Edited by Explopyro, 03 August 2010 - 10:52 PM.

I know the answer... wait, what was the question again?

My Diablo II guides:
Wind Druid
Armageddon Werewolf Druid

#2 rking

rking

    ↑ ↑ ↓↓←→←→BA

  • Administrators
  • 3,411 posts
  • Location: The past, where the good games are

Posted 02 April 2010 - 01:18 PM

I've reuploaded the PlugY settings file Explopyro originally edited, it's the same file mentioned in this topic.

PlugY (with caveats). PlugY is only acceptable here for certain specific purposes: to enable Diablo Clone and Chaos Tristram content in SP (and it may also be used to run multiple instances of the game if you wish to do so). Stat point and skill point reassignment are not allowed, nor is the use of any other features in PlugY including stash modifications and shared stashes. We have an "official" version of PlugY.ini (the settings file) which disables all of the "illegal" features which you should download if you plan to use this mod at all.



I only do this because I couldn't find it so I figured I'd put it somewhere everyone should be able to remember.

Attached Files


Posted Image
*-->My guides, click on either to view: Mercenary Guide and Berserker Guide.

#3 Mara

Mara
  • Members
  • 50 posts

Posted 10 July 2010 - 12:26 PM

Again, I feel a little confused...

If I say, want to run the Runewords mod in conjunction with PlugY, I add those lines to the PlugY shortcut instead, since PlugY.exe will function as Diablo II.exe?

Nevermind, I did not know a feature of PlugY was to enable Ladder only runewords! I guess problem solved :) I thought PlugY only emulated the Ladder only events.

Edited by Mara, 10 July 2010 - 12:32 PM.


#4 Heka

Heka

    Modorate noob

  • Donors
  • 229 posts
  • Location: Finland

Posted 10 July 2010 - 09:52 PM

then reinstall the game from scratch (either from the discs or from Blizzard's digital download) and update to 1.13, then install PlugY

There should read update to 1.12, right?

#5 Mara

Mara
  • Members
  • 50 posts

Posted 11 July 2010 - 05:44 AM

I just want to note as well that if you download the installers from battle.net, the game will automatically be updated to 1.12 so no patching needed.

#6 Explopyro

Explopyro

    Moderator

  • Moderators
  • 1,626 posts
  • Location: Pittsburgh, PA

Posted 03 August 2010 - 10:52 PM

Wow. This topic has been here since March and it took until July for someone to catch that typo? It's fixed now.
I know the answer... wait, what was the question again?

My Diablo II guides:
Wind Druid
Armageddon Werewolf Druid




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users